Aptly: package in repo but can't be installed

I'm setting up a repo by doing the following:

aptly repo create sample_repo
aptly repo add sample_repo neuboxdb-0.9.0-amd64.deb
aptly snapshot create sample_snapshot from repo sample_repo
aptly publish snapshot sample_snapshot
aptly serve

The web server starts on port 8080.

I then add the following to sources.list on a x86-64 machine:

deb [arch=amd64] http://[ip address of server:8080/ xenial universe

Next I run:

sudo apt-get update

Which returns:

W: http://[server ip]:8080/dists/xenial/InRelease: Signature by key EB45DBC87E77FEA9CB66C1D13FB76626D9985912 uses weak digest algorithm (SHA1)

But when I run:

sudo apt-get install neuboxdb

I get:

E: Unable to locate package neuboxdb

Looking in /var/lib/apt/lists on the machine I'm installing onto, I see an InRelease file corresponding to the server, but no amd64_Packages file.

On the repo machine, ~/.aptly/public/dists/xenial/main/binary-amd64 contains an entry for neuboxdb.

What's not right with this?

Answers 1

  • Such a nice tool to know about thank you. Well, could you compare these:

    sources.list on on x86-64 machine:

    deb [arch=amd64] http://[ip address of server]:8080/ xenial universe
    

    ...

    On the repo machine,

    ~/.aptly/public/dists/xenial/main/binary-amd64
    

    See the component, it is not the same, so your sources.list should have something like:

    deb [arch=amd64] http://[ip address of server]:8080/ xenial main
    

Related Questions