Unable to boot ubuntu from usb

I want to install Ubuntu in my laptop from a LiveUSB and prepared the USB drive accordingly. When my laptop restarts and I press F2 and go to boot options, I see this.

How do I boot from USB? There is no boot device pririty option to choose from.

Answers 3

  • Disable "Secure Boot" and enable "Load legacy Option Rom". It will turn "Boot list options" from black to blue, which otherwise stays black and doesn't allow to change the boot priority order. Pressing enter on "Boot list options" will take you to the list of options whether you want to prioritize boot from hard disk or usb or etc. Make Usb priority. Restart your computer and press 12 (for dell) when your computer company logo appears on screen. It will take you to installation.

    What is UEFI

    Back in old days, computers would come with legacy boot options which would easily allow other viruses to boot into your operating system other than your desired OS. UEFI solved this. Computers with UEFI, allows only pre-installed windows to boot. Hence disabling you and viruses to boot into computer. If you want to do so, make sure you do above suggested things and it would work perfectly.

    Note

    Make sure you make bootable usb using Rufus and check "UEFI" instead of "Legacy". Otherwise usb wont be booting compatible with your UEFI computer


  • Madeleine Was this an answer to the question ? it was totally unrelated, Try removing the USB and then looking at your boot options and then insert USB and see the boot options did it change anything ?

    Alternatively you can simple enable the option "BOOT FROM USB DEVICE FIRST"


  • First, in Dell's BIOS, make sure booting from a USB device is not disabled. Then, reboot, and use the F12 key during boot to pick the Boot Device Menu. From there, select the LiveUSB you inserted in the computer's USB port.


Related Questions