How to disable annoying freedesktop service login sound

I have a problem with service login/logout sound playing from time to time. This is extremely annoying it disturbs movie watching, music everything.I have also no idea what is this sound notification supposed to be telling me.

The sound files are located here:

/usr/share/sounds/freedesktop/stereo/service-login.oga
/usr/share/sounds/freedesktop/stereo/service-logout.oga

Removing or renaming these files does not stop the sound from playing. Can you help me out to disable the sound notification?

This is my configuration:

 OS: Ubuntu 18.04 bionic
 Kernel: x86_64 Linux 4.15.0-23-generic
 Shell: bash 4.4.19
 Resolution: 3840x1080
 DE: GNOME 
 WM: GNOME Shell
 WM Theme: Adwaita
 GTK Theme: Flat Remix GTK [GTK2/3]
 Icon Theme: Obsidian-Sand
 Font: Lato 10
 CPU: Intel Core i5-7200U @ 4x 3.1GHz [49.0°C]
 GPU: Mesa DRI Intel(R) HD Graphics 620 (Kaby Lake GT2) 
 RAM:  3839MiB

The problem is present when I use Gnome Wayland desktop, cinnamon desktop as well as with Awesomewm window manager. Any ideas how to disable this sound?

EDIT: Thanks for suggestions, I can see that journalctl shows this message around the time that the sound occurs:

Jun 25 21:17:24 marek-HP-ProBook-430-G4 terminator[7281]: Loading IM context type 'xim' failed
Jun 25 21:17:24 marek-HP-ProBook-430-G4 terminator[7281]: Loading IM context type 'xim' failed
Jun 25 21:17:24 marek-HP-ProBook-430-G4 terminator[7281]: Loading IM context type 'xim' failed
Jun 25 21:18:31 marek-HP-ProBook-430-G4 im.dino.Dino.desktop[4711]: [*****@wiuwiu.de] New connection with resource dino.f6849421: 0x5619eeb0c6e0
Jun 25 21:18:31 marek-HP-ProBook-430-G4 im.dino.Dino.desktop[4711]: [*****@wiuwiu.de] Error: GLib.IOError: Operation was cancelled
Jun 25 21:18:31 marek-HP-ProBook-430-G4 im.dino.Dino.desktop[4711]: [*****@wiuwiu.de] Check reconnect in 3 sec
Jun 25 21:18:35 marek-HP-ProBook-430-G4 systemd[1]: Starting Cleanup of Temporary Directories...
Jun 25 21:18:35 marek-HP-ProBook-430-G4 systemd[1]: Started Cleanup of Temporary Directories.

The culprit is Pidgin, when I close it the problem stops. It seems that the Pidgin is reconnecting to xmpp/jabber server every once in a while and causing this problem. Dino jabber client is reconnecting too but there is no associated sound to it. I have disabled all the notifications apart from the incoming message and the annoying sound is gone. Thanks!

Answers 2

  • You need to find out what is generating the system sound. The next time it happens immediately open a terminal and type journalctl -b. Then press the End key and read what program is issuing the sound.

    If nothing appears press q to quit. Then type dmesg and look for an offending program there. The timestamps are important for linking the program in question to the time the sound occurred.


  • Open Pulseaudio Volume Control playback tab

    pavucontrol -t 1
    

    For "System Sounds" reduce volume to 0 and/or enable mute button


Related Questions